Monitoring Integrations

Octoperf supports monitoring a variety of web servers, application servers, databases, operating systems and more.

Apache Httpd

Apache Httpd is a well known web-server mostly used as frontend or for PHP web applications. Httpd 2.2.xx and 2.4.xx with mod_status enabled are supported.

Apache Httpd

Apache Tomcat

Apache Tomcat is an open-source web server which can be monitored using the JMX protocol. Apache Tomcat 7 and above can be monitored.

Apache Tomcat

Generic JMX

The Generic JMX module supports virtually any web-server exposing metrics through the JMX protocol.

Generic JMX

Lighttpd

Lighttpd is a high performance frontend webserver. With its memory footprint, it is the perfect solution for every server that is suffering load problems. Lighttpd 1 and 2 are supported.

Lighttpd

Linux

Visualize your overall Linux performance as well as system level metrics like CPU, disk I/O, or memory usage. Latest Debian, Fedora and Ubuntu are supported.

Linux

MongoDB

MongoDB is a free and open-source cross-platform document-oriented database. OctoPerf supports MongoDB database servers version 3.4 and above.

MongoDB

MySQL

OctoPerf collects 30+ key monitoring metrics from your MySQL database. Version 5 and above are supported.

MySQL

Nginx

NGINX is a popular HTTP server and reverse proxy server. Open-source Nginx server are supported.

Nginx

Oracle

Oracle DB is the leading enterprise database being used by most of the Fortune 500 companies. We support Oracle Database server versions: 8i, 9i, 10g, 11g and 12c.

Oracle

PostgreSQL

PostgreSQL is a sophisticated open-source Object-Relational DBMS supporting almost all SQL constructs. OctoPerf supports PostgreSQL version 8 and above.

PostgreSQL

SQL Server

Microsoft SQL Server is a popular database for web applications mostly powered by Microsoft IIS servers. All Microsoft SQL Server versions are supported.

SQL Server

Windows

Microsoft Windows is the leading operating system for PCs. OctoPerf supports monitoring Windows 7, 8, 8.1 and 10. As well as Microsoft IIS v6 or newer.

Windows

Contact Us

You need to monitor something not listed here? Contact us, we can probably add it in no time!

Contact Us